<< Previous Message Main Index Next Message >>
<< Previous Message in Thread This Month Next Message in Thread >>
Date   : Sat, 11 Jul 2009 18:58:46 +0100
From   : C.J.Thornley@... (Chris Thornley)
Subject: Master Ethernet upgrade

> A bridge is specifically defined as a same-network to same-network 
> connection,
> By whom? Citation?

A bridge is esentially a 2 port managed swtch. This operates at Layer 2 and
the layers below it.
This is generally the CISCO defination.

>So as this device process packets based on the Econet hardware address, it
functions as a bridge. It also 
>then converts packets to the IP protocol and forwards them as a router. It
also provides translation 
>between the networks

A device is catograised by the higest layer it can operate on. Layer 3
devices can operate also on Layer 2 and Layer 1

>a gateway and can runs daemons at the application level - a server, some of
which e.g. SMTP will be a proxy.
Yes this is a layer 7 device capacble of operting on layer 7 and the layers
below it.
But this over complicates things and esentially is not needed and will be
slower. 
You only need a layer 3 device to do this task.

This makes me wonder that if there is simple confusion here, what on earth
is the software going to be like?

A router or a managed switch runs a startup-config which becomes a
running-config once the device is booted.
Hopefully things will operate like this on this piece of hardware.

Here is an example of a typical simple router configuration.
The router in this case has 2 serial interfaces and 2 ethernet ports. This
is configured for a specific senario but you get the picture.

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Lab_C1
!
enable secret 5 $1$KM4e$QRKiRS8bjotGXJTHpq8ip0
enable password 7 14141B180F0B
!
ip subnet-zero
!
!
!
ip host Lab_A1 172.16.1.1 172.16.12.1 172.16.6.1
ip host Lab_B1 172.16.2.1 172.16.7.1  172.16.6.2
ip host Lab_C1 172.16.3.1 172.16.8.1  172.16.7.2
ip host Lab_D1 172.16.4.1 172.16.8.2
ip host Lab_E1 172.16.4.2
!
!
!
interface FastEthernet0/0
 description Connection to Small Hub 3
 ip address 172.16.3.1 255.255.255.0
 duplex auto
 speed auto
no shutdown
!
interface FastEthernet0/1
shutdown
!
interface Serial0/0
 description Serial Lab_C1s0 to lab_D1s1
 bandwidth 56
 ip address 172.16.8.1 255.255.255.0
 clockrate 56000
 no shutdown
!
interface Serial0/1
 description Serial Lab_C1s1 to Lab_B1s0
 bandwidth 56
 ip address 172.16.7.2 255.255.255.0
 clockrate 56000
 no shutdown
!
router rip
 network 172.16.0.0
 network 192.168.9.0
!
ip classless
ip http server
ip pim bidir-enable
ip default-gateway 192.168.9.99
!
!
banner motd # LAB_C1 Router #
!
!
line con 0
 password 7 104D000A0618
 login
 speed 115200
line aux 0
 password 7 104D000A0618
 login
 speed 115200
line vty 0 4
 password 7 070C285F4D06
 login
!
!
end

Chris




               />      Christopher J. Thornley is cjt@...                 
  (           //------------------------------------------------------,
 (*)OXOXOXOXO(*>=*=O=S=U=0=3=6=*=---------                             >
  (           \\------------------------------------------------------'
               \>       Home Page :-http://www.coolrose.fsnet.co.uk
 
-----Original Message-----
From: bbc-micro-bounces+c.j.thornley=coolrose.fsnet.co.uk@...               
[mailto:bbc-micro-bounces+c.j.thornley=coolrose.fsnet.co.uk@...             
uk] On Behalf Of Mark Usher
Sent: 11 July 2009 10:07
To: bbc-micro@...               
Subject: Re: [BBC-Micro] Master Ethernet upgrade







- 

Suggestions for a new name on a postcard...

-Mark
       


_______________________________________________
bbc-micro mailing list
bbc-micro@...               
http://lists.cloud9.co.uk/mailman/listinfo/bbc-micro
<< Previous Message Main Index Next Message >>
<< Previous Message in Thread This Month Next Message in Thread >>